What’s Vulnerable › Vulnerabilities
CVE-2024-7553: Accessing Untrusted Directory May Allow Local Privilege Escalation
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-07 · updated 2026-06-17
- Weakness: CWE-284
Description
Incorrect validation of files loaded from a local untrusted directory may allow local privilege escalation if the underlying operating systems is Windows. This may result in the application executing arbitrary behaviour determined by the contents of untrusted files. This issue affects MongoDB Server v5.0 versions prior to 5.0.27, MongoDB Server v6.0 versions prior to 6.0.16, MongoDB Server v7.0 versions prior to 7.0.12, MongoDB Server v7.3 versions prior 7.3.3, MongoDB C Driver versions prior to 1.26.2 and MongoDB PHP Driver versions prior to 1.18.1. Required Configuration: Only environments with Windows as the underlying operating system is affected by this issue
Affected products
- MongoDB C# Driver: before 1.26.2 — fixed in 1.26.2
- MongoDB: from 5.0.0 before 5.0.27; from 6.0.0 before 6.0.16; from 7.0.0 before 7.0.12; from 7.3.0 before 7.3.3 — fixed in 5.0.27, 6.0.16, 7.0.12, 7.3.3
- MongoDB PHP Driver: before 1.18.1 — fixed in 1.18.1
How to fix
Upgrade to a fixed version: MongoDB C# Driver 1.26.2; MongoDB 5.0.27, 6.0.16, 7.0.12, 7.3.3; MongoDB PHP Driver 1.18.1. Check the vendor advisory for mitigations.
References
- https://jira.mongodb.org/browse/CDRIVER-5650
- https://jira.mongodb.org/browse/PHPC-2369
- https://jira.mongodb.org/browse/SERVER-93211
Get alerted when CVE-2024-7553 or the next vulnerability affects your stack