What’s Vulnerable › Vulnerabilities
CVE-2024-7554: Exposure of Sensitive Information to an Unauthorized Actor in GitLab
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-200
Description
An issue has been discovered in GitLab CE/EE affecting all versions starting from 13.9 before 17.0.6, all versions starting from 17.1 before 17.1.4, all versions starting from 17.2 before 17.2.2. Under certain conditions, access tokens may have been logged when an API request was made in a specific manner.
Affected products
- GitLab: from 13.9 before 17.0.6; from 17.1.0 before 17.1.4; from 17.2.0 before 17.2.2 — fixed in 17.0.6, 17.1.4, 17.2.2
How to fix
Upgrade to a fixed version: GitLab 17.0.6, 17.1.4, 17.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7554 or the next vulnerability affects your stack