What’s Vulnerable › Vulnerabilities
CVE-2024-7574: Christmasify! <= 1.5.5 - Cross-Site Request Forgery to Stored Cross-Site Scripting
- Severity: medium (CVSS 6.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-12 · updated 2026-06-17
- Weakness: CWE-352
Description
The Christmasify! plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.5.5. This is due to missing nonce validation on the 'options' function. This makes it possible for unauthenticated attackers to modify the plugin's settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Affected products
- cyberfoxdigital Christmasify!: before 1.5.6 — fixed in 1.5.6
How to fix
Upgrade to a fixed version: cyberfoxdigital Christmasify! 1.5.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3132621/christmasify
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ac247d3a-9e60-431e-ac98-2601e9907758?source=cve
Get alerted when CVE-2024-7574 or the next vulnerability affects your stack