What’s Vulnerable › Vulnerabilities
CVE-2024-7599: Advanced Sermons <= 3.3 - Authenticated (Contributor+) Stored Cross-Site Scripting
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The Advanced Sermons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘sermon_video_embed’ parameter in all versions up to, and including, 3.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- WP Codeus Advanced Sermons: before 3.4 — fixed in 3.4
How to fix
Upgrade to a fixed version: WP Codeus Advanced Sermons 3.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/advanced-sermons/trunk/admin/meta/sermon-details.php#L396
- https://plugins.trac.wordpress.org/browser/advanced-sermons/trunk/include/templates/sections/video-template.php#L124
- https://plugins.trac.wordpress.org/browser/advanced-sermons/trunk/include/templates/sections/video-template.php#L18
- https://plugins.trac.wordpress.org/changeset/3147283/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/41859e1c-1ae0-49f1-82d3-5af3c15994ef?source=cve
Get alerted when CVE-2024-7599 or the next vulnerability affects your stack