What’s Vulnerable › Vulnerabilities
CVE-2024-7605: HelloAsso <= 1.1.10 - Missing Authorization to Authenticated (Contributor+) Limited Options Update
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-05 · updated 2026-06-17
- Weakness: CWE-862
Description
The HelloAsso plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'ha_ajax' function in all versions up to, and including, 1.1.10. This makes it possible for authenticated attackers, with Contributor-level access and above, to update plugin options, potentially disrupting the service.
Affected products
- HelloAsso: before 1.1.11 — fixed in 1.1.11
How to fix
Upgrade to a fixed version: HelloAsso 1.1.11. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/helloasso/trunk/admin/class-hello-asso-admin.php#L457
- https://plugins.trac.wordpress.org/changeset/3145151/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/1690631b-0e5d-45d1-9db6-6ac426874762?source=cve
Get alerted when CVE-2024-7605 or the next vulnerability affects your stack