What’s Vulnerable › Vulnerabilities
CVE-2024-7607: Front End Users <= 3.2.28 - Authenticated (Contributor+) Time-Based SQL Injection
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-29 · updated 2026-06-17
- Weakness: CWE-89
Description
The Front End Users plugin for WordPress is vulnerable to time-based SQL Injection via the ‘order’ parameter in all versions up to, and including, 3.2.28 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Contributor-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Affected products
- rustaurius Front End Users: before 3.2.29 — fixed in 3.2.29
How to fix
Upgrade to a fixed version: rustaurius Front End Users 3.2.29. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/front-end-only-users/trunk/html/UsersPage.php#L42
- https://plugins.trac.wordpress.org/browser/front-end-only-users/trunk/html/UsersPage.php#L60
- https://plugins.trac.wordpress.org/browser/front-end-only-users/trunk/html/UsersPage.php#L63
- https://plugins.trac.wordpress.org/browser/front-end-only-users/trunk/html/UsersPage.php#L76
- https://plugins.trac.wordpress.org/changeset/3142978/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/ec162cdc-d4cd-47d9-b941-24bfee6c48fd?source=cve
Get alerted when CVE-2024-7607 or the next vulnerability affects your stack