What’s Vulnerable › Vulnerabilities
CVE-2024-7610: Uncontrolled Resource Consumption in GitLab
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-08 · updated 2026-06-17
- Weakness: CWE-400
Description
A Denial of Service (DoS) condition has been discovered in GitLab CE/EE affecting all versions starting with 15.9 before 17.0.6, 17.1 prior to 17.1.4, and 17.2 prior to 17.2.2. It is possible for an attacker to cause catastrophic backtracking while parsing results from Elasticsearch.
Affected products
- GitLab: from 15.9.0 before 17.0.6; from 17.1.0 before 17.1.4; from 17.2.0 before 17.2.2 — fixed in 17.0.6, 17.1.4, 17.2.2
How to fix
Upgrade to a fixed version: GitLab 17.0.6, 17.1.4, 17.2.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7610 or the next vulnerability affects your stack