What’s Vulnerable › Vulnerabilities
CVE-2024-7620: Customizer Export/Import <= 0.9.7 - Authenticated (Admin+) Arbitrary File Upload via Customization Settings Import
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-07 · updated 2026-06-17
- Weakness: CWE-434
Description
The Customizer Export/Import plugin for WordPress is vulnerable to arbitrary file uploads due to missing file type validation in the '_import' function in all versions up to, and including, 0.9.7. This makes it possible for authenticated attackers, with Administrator-level access and above, to upload arbitrary files on the affected site's server which may make remote code execution possible. NOTE: This vulnerability is only exploitable when used in conjunction with a race condition as the uploaded file is deleted shortly after it is created.
Affected products
- Customizer Export/Import: before 0.9.7.1 — fixed in 0.9.7.1
How to fix
Upgrade to a fixed version: Customizer Export/Import 0.9.7.1. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3144365/customizer-export-import
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7600e7df-725d-4877-b0bf-5329f814723f?source=cve
Get alerted when CVE-2024-7620 or the next vulnerability affects your stack