What’s Vulnerable › Vulnerabilities
CVE-2024-7624: Zephyr Project Manager <= 3.3.101 - Authenticated (Subscriber+) Limited Privilege Escalation
- Severity: high (CVSS 8.1 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-15 · updated 2026-06-17
- Weakness: CWE-285
Description
The Zephyr Project Manager plugin for WordPress is vulnerable to limited privilege escalation in all versions up to, and including, 3.3.101. This is due to the plugin not properly checking a users capabilities before allowing them to enable access to the plugin's settings through the update_user_access() function. This makes it possible for authenticated attackers, with subscriber-level access and above, to grant themselves full access to the plugin's settings.
Affected products
- Dylan James Zephyr Project Manager: before 3.3.102 — fixed in 3.3.102
How to fix
Upgrade to a fixed version: Dylan James Zephyr Project Manager 3.3.102. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/zephyr-project-manager/trunk/includes/Base/AjaxHandler.php?rev=3111536#L2464
- https://plugins.trac.wordpress.org/changeset/3134404/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/b9ef344d-cd56-43f9-b185-de83a92800de?source=cve
Get alerted when CVE-2024-7624 or the next vulnerability affects your stack