What’s Vulnerable › Vulnerabilities
CVE-2024-7630: Relevanssi <= 4.22.2 (Free) and <= 2.25.1 (Premium) - Unauthenticated Information Exposure
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-16 · updated 2026-06-17
- Weakness: CWE-200
Description
The Relevanssi – A Better Search plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 4.22.2 (Free) and 2.25.1 (Premium) via the relevanssi_do_query() due to insufficient limitations on the posts that are returned when searching. This makes it possible for unauthenticated attackers to extract potentially sensitive information from password protected posts.
Affected products
- Relevanssi: before 4.23.0 — fixed in 4.23.0
How to fix
Upgrade to a fixed version: Relevanssi 4.23.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/changeset/3134753/relevanssi/trunk/lib/common.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3fa78f4e-ede2-4863-a2d7-99bd8c7b5912?source=cve
Get alerted when CVE-2024-7630 or the next vulnerability affects your stack