What’s Vulnerable › Vulnerabilities
CVE-2024-7634: NGINX Agent Vulnerability
- Severity: medium (CVSS 4.9 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-22 · updated 2026-06-17
- Weakness: CWE-22
Description
NGINX Agent's "config_dirs" restriction feature allows a highly privileged attacker to gain the ability to write/overwrite files outside of the designated secure directory.
Affected products
- F5 NGINX Agent: from 2.17.0 before 2.37.0 — fixed in 2.37.0
- F5 NGINX Instance Manager: from 2.3.1 before 2.17.2 — fixed in 2.17.2
How to fix
Upgrade to a fixed version: F5 NGINX Agent 2.37.0; F5 NGINX Instance Manager 2.17.2. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7634 or the next vulnerability affects your stack