What’s Vulnerable › Vulnerabilities
CVE-2024-7646
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 27.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-16 · updated 2026-06-17
- Weakness: CWE-20
Description
A security issue was discovered in ingress-nginx where an actor with permission to create Ingress objects (in the `networking.k8s.io` or `extensions` API group) can bypass annotation validation to inject arbitrary commands and obtain the credentials of the ingress-nginx controller. In the default configuration, that credential has access to all secrets in the cluster.
Affected products
- Kubernetes ingress-nginx: from 1.11.0 before 1.11.2; before 1.10.4; 1.11.2, 1.10.4 — fixed in 1.10.4, 1.11.2
How to fix
Upgrade to a fixed version: Kubernetes ingress-nginx 1.10.4, 1.11.2. Check the vendor advisory for mitigations.
References
- https://github.com/kubernetes/ingress-nginx/pull/11719
- https://github.com/kubernetes/ingress-nginx/pull/11721
- https://github.com/kubernetes/kubernetes/issues/126744
- https://groups.google.com/g/kubernetes-security-announce/c/a1__cKjWkfA
- http://www.openwall.com/lists/oss-security/2024/08/16/5
Get alerted when CVE-2024-7646 or the next vulnerability affects your stack