What’s Vulnerable › Vulnerabilities
CVE-2024-7655: Community by PeepSo – Social Network, Membership, Registration, User Profiles <= 6.4.5.0 - Authenticated (Administrator+) Stored Cross-Site Scripting
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Community by PeepSo – Social Network, Membership, Registration, User Profiles plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 6.4.5.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This only affects multi-site installations and installations where unfiltered_html has been disabled.
Affected products
- PeepSo Community by PeepSo – Social Network, Membership, Registration, User Profiles: before 6.4.6.0 — fixed in 6.4.6.0
How to fix
Upgrade to a fixed version: PeepSo Community by PeepSo – Social Network, Membership, Registration, User Profiles 6.4.6.0. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/peepso-core/tags/6.4.6.0/classes/adminconfigfields.php?rev=3147528#L17
- https://plugins.trac.wordpress.org/changeset/3147528/
- https://wordpress.org/plugins/peepso-core/#developers
- https://www.peepso.com/6-4-6-0/
- https://www.peepso.com/changelog/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/e85ee611-ae81-4736-b4f0-b9d06714da18?source=cve
Get alerted when CVE-2024-7655 or the next vulnerability affects your stack