What’s Vulnerable › Vulnerabilities

CVE-2024-7711

Description

An Incorrect Authorization vulnerability was identified in GitHub Enterprise Server, allowing an attacker to update the title, assignees, and labels of any issue inside a public repository. This was only exploitable inside a public repository. This vulnerability affected GitHub Enterprise Server versions before 3.14 and was fixed in versions 3.13.3, 3.12.8, and 3.11.14. Versions 3.10 of GitHub Enterprise Server are not affected. This vulnerability was reported via the GitHub Bug Bounty program.

Affected products

How to fix

Upgrade to a fixed version: GitHub Enterprise Server 3.11.14, 3.12.8, 3.13.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-7711 or the next vulnerability affects your stack