What’s Vulnerable › Vulnerabilities
CVE-2024-7714: AI Assistant with ChatGPT by AYS <= 2.0.9 - Unauthenticated AJAX Calls
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-27 · updated 2026-06-17
Description
The AI ChatBot with ChatGPT and Content Generator by AYS WordPress plugin before 2.1.0 lacks sufficient access controls allowing an unauthenticated user to disconnect the AI ChatBot with ChatGPT and Content Generator by AYS WordPress plugin before 2.1.0 from OpenAI, thereby disabling the AI ChatBot with ChatGPT and Content Generator by AYS WordPress plugin before 2.1.0. Multiple actions are accessible: 'ays_chatgpt_disconnect', 'ays_chatgpt_connect', and 'ays_chatgpt_save_feedback'
Affected products
- AI ChatBot with ChatGPT and Content Generator by AYS: before 2.1.0 — fixed in 2.1.0
How to fix
Upgrade to a fixed version: AI ChatBot with ChatGPT and Content Generator by AYS 2.1.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7714 or the next vulnerability affects your stack