What’s Vulnerable › Vulnerabilities
CVE-2024-7724: Foxit PDF Reader AcroForm Use-After-Free Remote Code Execution Vulnerability
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.8% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-21 · updated 2026-06-17
- Weakness: CWE-416
Description
Foxit PDF Reader AcroForm Use-After-Free Remote Code Execution Vulnerability. This vulnerability allows remote attackers to execute arbitrary code on affected installations of Foxit PDF Reader. User interaction is required to exploit this vulnerability in that the target must visit a malicious page or open a malicious file. The specific flaw exists within the handling of AcroForms. The issue results from the lack of validating the existence of an object prior to performing operations on the object. An attacker can leverage this vulnerability to execute code in the context of the current process. Was ZDI-CAN-23900.
Affected products
- Foxit PDF Reader: before 11.2.11.54113; from 12.0.0.12394 before 12.1.8.15703; from 13.0.0.21632 before 13.1.3.22478; from 2023.1.0.15510 before 2024.2.3.25184 — fixed in 11.2.11.54113, 12.1.8.15703, 13.1.3.22478, 2024.2.3.25184
- Foxit Pdf Reader: before 2024.2.3.25184 — fixed in 2024.2.3.25184
How to fix
Upgrade to a fixed version: Foxit PDF Reader 11.2.11.54113, 12.1.8.15703, 13.1.3.22478, 2024.2.3.25184; Foxit Pdf Reader 2024.2.3.25184. Check the vendor advisory for mitigations.
References
- https://www.foxit.com/support/security-bulletins.html
- https://www.zerodayinitiative.com/advisories/ZDI-24-1126/
Get alerted when CVE-2024-7724 or the next vulnerability affects your stack