What’s Vulnerable › Vulnerabilities
CVE-2024-7727: HTML5 Video Player – mp4 Video Player Plugin and Block <= 2.5.32 - Missing Authorization in multiple functions via h5vp_ajax_handler
- Severity: medium (CVSS 5.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-11 · updated 2026-06-17
- Weakness: CWE-862
Description
The HTML5 Video Player – mp4 Video Player Plugin and Block plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on multiple functions called via the 'h5vp_ajax_handler' ajax action in all versions up to, and including, 2.5.32. This makes it possible for unauthenticated attackers to call these functions to manipulate data.
Affected products
- bplugins HTML5 Video Player – Embed and Play Videos in Custom Player: before 2.5.33 — fixed in 2.5.33
How to fix
Upgrade to a fixed version: bplugins HTML5 Video Player – Embed and Play Videos in Custom Player 2.5.33. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/html5-video-player/trunk/inc/Model/Ajax.php#L5
- https://plugins.trac.wordpress.org/browser/html5-video-player/trunk/inc/Model/ImportData.php#L4
- https://plugins.trac.wordpress.org/changeset/3139559/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/908df18e-7178-4d40-becb-86e1a714a7da?source=cve
Get alerted when CVE-2024-7727 or the next vulnerability affects your stack