What’s Vulnerable › Vulnerabilities
CVE-2024-7747: Wallet for WooCommerce <= 1.5.6 - Authenticated (Subscriber+) Incorrect Conversion between Numeric Types
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-28 · updated 2026-06-17
- Weakness: CWE-681
Description
The Wallet for WooCommerce plugin for WordPress is vulnerable to incorrect conversion between numeric types in all versions up to, and including, 1.5.6. This is due to a numerical logic flaw when transferring funds to another user. This makes it possible for authenticated attackers, with Subscriber-level access and above, to create funds during a transfer and distribute these funds to any number of other users or their own account, rendering products free. Attackers could also request to withdraw funds if the Wallet Withdrawal extension is used and the request is approved by an administrator.
Affected products
- StandaloneTech TeraWallet – For WooCommerce: before 1.5.7 — fixed in 1.5.7
How to fix
Upgrade to a fixed version: StandaloneTech TeraWallet – For WooCommerce 1.5.7. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/woo-wallet/trunk/includes/class-woo-wallet-frontend.php#L407
- https://plugins.trac.wordpress.org/changeset/3145131/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/fd8f3eb7-ac60-46c4-b41f-5d89e3133042?source=cve
Get alerted when CVE-2024-7747 or the next vulnerability affects your stack