What’s Vulnerable › Vulnerabilities
CVE-2024-7759: PWA For WP & AMP < 1.7.72 Administrator+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-79
Description
The PWA for WP WordPress plugin before 1.7.72 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup).
Affected products
- magazine3 PWA for WP – Progressive Web Apps Made Simple: before 1.7.72 — fixed in 1.7.72
How to fix
Upgrade to a fixed version: magazine3 PWA for WP – Progressive Web Apps Made Simple 1.7.72. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7759 or the next vulnerability affects your stack