What’s Vulnerable › Vulnerabilities
CVE-2024-7791: 140+ Widgets | Xpro Addons For Elementor – FREE <= 1.4.4.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via Post Grid Widget
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-27 · updated 2026-06-17
- Weakness: CWE-79
Description
The 140+ Widgets | Xpro Addons For Elementor – FREE plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘arrow’ parameter within the Post Grid widget in all versions up to, and including, 1.4.4.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- Xpro Addons — 140+ Widgets for Elementor: before 1.4.4.4 — fixed in 1.4.4.4
How to fix
Upgrade to a fixed version: Xpro Addons — 140+ Widgets for Elementor 1.4.4.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/xpro-elementor-addons/trunk/widgets/post-grid/post-grid.php#L1891
- https://plugins.trac.wordpress.org/changeset/3141892/
- https://plugins.trac.wordpress.org/changeset/3141892/#file2
- https://wordpress.org/plugins/xpro-elementor-addons/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/c6025dd5-a1d7-48cc-90b3-f020d3d2298b?source=cve
Get alerted when CVE-2024-7791 or the next vulnerability affects your stack