What’s Vulnerable › Vulnerabilities
CVE-2024-7836: Themify Builder <= 7.6.1 - Missing Authorization to Authenticated (Contributor+) Post Duplication
- Severity: medium (CVSS 4.3 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-22 · updated 2026-06-17
- Weakness: CWE-863
Description
The Themify Builder plugin for WordPress is vulnerable to unauthorized post duplication due to missing checks on the duplicate_page_ajaxify function in all versions up to, and including, 7.6.1. This makes it possible for authenticated attackers, with Contributor-level access and above, to duplicate and view private or draft posts created by other users that otherwise shouldn't be accessible to them.
Affected products
- themifyme Themify Builder: before 7.6.2 — fixed in 7.6.2
How to fix
Upgrade to a fixed version: themifyme Themify Builder 7.6.2. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/themify-builder/tags/7.6.1/classes/class-builder-duplicate-page.php#L41
- https://www.wordfence.com/threat-intel/vulnerabilities/id/31dfc46c-a673-41f1-b701-aa832f004ebc?source=cve
Get alerted when CVE-2024-7836 or the next vulnerability affects your stack