What’s Vulnerable › Vulnerabilities
CVE-2024-7846: YITH WooCommerce Ajax Search < 2.7.1 - Contributor+ Stored XSS
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-23 · updated 2026-06-17
- Weakness: CWE-79
Description
YITH WooCommerce Ajax Search is vulnerable to a XSS vulnerability due to insufficient sanitization of user supplied block attributes. This makes it possible for Contributors+ attackers to inject arbitrary scripts.
Affected products
- YITHEMES YITH WooCommerce Ajax Search: before 2.7.1 — fixed in 2.7.1
How to fix
Upgrade to a fixed version: YITHEMES YITH WooCommerce Ajax Search 2.7.1. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7846 or the next vulnerability affects your stack