What’s Vulnerable › Vulnerabilities
CVE-2024-7877: Appointment Booking Calendar < 1.6.7.55 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-05 · updated 2026-06-17
- Weakness: CWE-79
Description
The Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin WordPress plugin before 1.6.7.55 does not sanitise and escape some of its Notification settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin: before 1.6.7.55 — fixed in 1.6.7.55
How to fix
Upgrade to a fixed version: Appointment Booking Calendar — Simply Schedule Appointments Booking Plugin 1.6.7.55. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7877 or the next vulnerability affects your stack