What’s Vulnerable › Vulnerabilities
CVE-2024-7879: WP ULike < 4.7.5 - Admin+ Stored XSS via Widgets
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-06 · updated 2026-06-17
- Weakness: CWE-79
Description
The WP ULike WordPress plugin before 4.7.5 does not sanitise and escape some of its settings, which could allow high privilege users such as editors to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- WP ULike: before 4.7.5 — fixed in 4.7.5
How to fix
Upgrade to a fixed version: WP ULike 4.7.5. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7879 or the next vulnerability affects your stack