What’s Vulnerable › Vulnerabilities
CVE-2024-7891: Floating Contact Button < 2.8 - Admin+ Stored XSS
- Severity: medium (CVSS 4.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-09-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Floating Contact Button WordPress plugin before 2.8 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed
Affected products
- Floating Contact Button: before 2.8 — fixed in 2.8
How to fix
Upgrade to a fixed version: Floating Contact Button 2.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7891 or the next vulnerability affects your stack