What’s Vulnerable › Vulnerabilities
CVE-2024-7895: Beaver Builder (Lite Version) <= 2.8.3.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via type Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-29 · updated 2026-06-17
- Weakness: CWE-79
Description
The Beaver Builder – WordPress Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘type’ parameter in all versions up to, and including, 2.8.3.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- beaverbuilder Beaver Builder Page Builder – Drag and Drop Website Builder: before 2.8.3.6 — fixed in 2.8.3.6
How to fix
Upgrade to a fixed version: beaverbuilder Beaver Builder Page Builder – Drag and Drop Website Builder 2.8.3.6. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/beaver-builder-lite-version/trunk/modules/button-group/button-group.php#L195
- https://plugins.trac.wordpress.org/browser/beaver-builder-lite-version/trunk/modules/button-group/includes/frontend.php#L2
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3143080%40beaver-builder-lite-version&new=3143080%40beaver-builder-lite-version&sfp_email=&sfph_mail=
- https://wordpress.org/plugins/beaver-builder-lite-version/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f83db067-843f-4dd8-b5d1-83e95c6c88cc?source=cve
- https://www.wpbeaverbuilder.com/change-logs/
Get alerted when CVE-2024-7895 or the next vulnerability affects your stack