What’s Vulnerable › Vulnerabilities
CVE-2024-7928: FastAdmin lang path traversal
- Severity: high (CVSS 7.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 16.9% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-08-19 · updated 2026-06-17
- Weakness: CWE-22
Description
A vulnerability, which was classified as problematic, has been found in FastAdmin up to 1.3.3.20220121. Affected by this issue is some unknown functionality of the file /index/ajax/lang. The manipulation of the argument lang leads to path traversal. The attack may be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 1.3.4.20220530 is able to address this issue. It is recommended to upgrade the affected component.
Affected products
- FastAdmin: before 1.3.4.20220530 — fixed in 1.3.4.20220530
How to fix
Upgrade to a fixed version: FastAdmin 1.3.4.20220530. Check the vendor advisory for mitigations.
References
- https://vuldb.com/?ctiid.275114
- https://vuldb.com/?id.275114
- https://vuldb.com/?submit.392202
- https://wiki.shikangsi.com/post/share/da0292b8-0f92-4e6e-bdb7-73f47b901acd
Get alerted when CVE-2024-7928 or the next vulnerability affects your stack