What’s Vulnerable › Vulnerabilities

CVE-2024-7954: SPIP porte_plume Plugin Arbitrary PHP Execution

Description

The porte_plume plugin used by SPIP before 4.30-alpha2, 4.2.13, and 4.1.16 is vulnerable to an arbitrary code execution vulnerability. A remote and unauthenticated attacker can execute arbitrary PHP as the SPIP user by sending a crafted HTTP request.

Affected products

How to fix

Upgrade to a fixed version: SPIP 4.1.16, 4.2.13, 4.3.0-alpha2. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-7954 or the next vulnerability affects your stack