What’s Vulnerable › Vulnerabilities
CVE-2024-7982: Registrations for The Events Calendar < 2.12.4 - Unauthenticated Stored XSS
- Severity: critical (CVSS 9.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2024-11-08 · updated 2026-06-17
- Weakness: CWE-79
Description
The Registrations for the Events Calendar WordPress plugin before 2.12.4 does not sanitise and escape some parameters when accepting event registrations, which could allow unauthenticated users to perform Cross-Site Scripting attacks.
Affected products
- Registrations for the Events Calendar – Event Registration Plugin: before 2.12.4 — fixed in 2.12.4
How to fix
Upgrade to a fixed version: Registrations for the Events Calendar – Event Registration Plugin 2.12.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7982 or the next vulnerability affects your stack