What’s Vulnerable › Vulnerabilities
CVE-2024-7987: Rockwell Automation ThinManager® ThinServer™ Information Disclosure and Remote Code Execution Vulnerabilities
- Severity: high (CVSS 7.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-26 · updated 2026-06-17
- Weakness: CWE-434
Description
A remote code execution vulnerability exists in the Rockwell Automation ThinManager® ThinServer™ that allows a threat actor to execute arbitrary code with System privileges. To exploit this vulnerability and a threat actor must abuse the ThinServer™ service by creating a junction and use it to upload arbitrary files.
Affected products
- Rockwellautomation Thinmanager Thinserver: from 11.1.0 before 11.1.8; from 11.2.0 before 11.2.9; from 12.0.0 before 12.0.7; from 12.1.0 before 12.1.8; from 13.0.0 before 13.0.5; from 13.1.0 before 13.1.3 — fixed in 11.1.8, 11.2.9, 12.0.7, 12.1.8, 13.0.5, 13.1.3
How to fix
Upgrade to a fixed version: Rockwellautomation Thinmanager Thinserver 11.1.8, 11.2.9, 12.0.7, 12.1.8. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7987 or the next vulnerability affects your stack