What’s Vulnerable › Vulnerabilities
CVE-2024-7998
- Severity: low (CVSS 2.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.2% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-21 · updated 2026-06-17
- Weakness: CWE-613
Description
In affected versions of Octopus Server OIDC cookies were using the wrong expiration time which could result in them using the maximum lifespan.
Affected products
- Octopus Deploy Octopus Server: from 2022.4.8332 before 2024.1.12931; from 2024.2.101 before 2024.2.9313 — fixed in 2024.1.12931, 2024.2.9313
How to fix
Upgrade to a fixed version: Octopus Deploy Octopus Server 2024.1.12931, 2024.2.9313. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-7998 or the next vulnerability affects your stack