What’s Vulnerable › Vulnerabilities

CVE-2024-8013: CSFLE and Queryable Encryption self-lookup may fail to encrypt values in subpipelines

Description

A bug in query analysis of certain complex self-referential $lookup subpipelines may result in literal values in expressions for encrypted fields to be sent to the server as plaintext instead of ciphertext. Should this occur, no documents would be returned or written. This issue affects mongocryptd binary (v5.0 versions prior to 5.0.29, v6.0 versions prior to 6.0.17, v7.0 versions prior to 7.0.12 and v7.3 versions prior to 7.3.4) and mongo_crypt_v1.so shared libraries (v6.0 versions prior to 6.0.17, v7.0 versions prior to 7.0.12 and v7.3 versions prior to 7.3.4) released alongside MongoDB Enterprise Server versions.

Affected products

How to fix

Upgrade to a fixed version: MongoDB Inc Mongo_crypt_v1.so 6.0.17, 7.0.12, 7.3.4; MongoDB Inc mongocryptd 5.0.29, 6.0.17, 7.0.12, 7.3.4. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-8013 or the next vulnerability affects your stack