What’s Vulnerable › Vulnerabilities
CVE-2024-8016: The Events Calendar Pro <= 7.0.2 - Authenticated (Administrator+) PHP Object Injection to Remote Code Execution
- Severity: high (CVSS 7.2 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-30 · updated 2026-06-17
- Weakness: CWE-502
Description
The Events Calendar Pro plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 7.0.2 via deserialization of untrusted input from the 'filters' parameter in widgets. This makes it possible for authenticated attackers, with administrator-level access and above, to inject a PHP Object. The additional presence of a POP chain allows attackers to execute code remotely. In certain configurations, this can be exploitable by lower level users. We confirmed that this plugin installed with Elementor makes it possible for users with contributor-level access and above to exploit this issue.
Affected products
- theeventscalendar The Events Calendar Pro: before 7.0.2.1 — fixed in 7.0.2.1
How to fix
Upgrade to a fixed version: theeventscalendar The Events Calendar Pro 7.0.2.1. Check the vendor advisory for mitigations.
References
- https://theeventscalendar.com/blog/news/important-security-update-for-the-events-calendar-pro/
- https://theeventscalendar.com/release-notes/events-calendar-pro/events-calendar-pro-7-0-2-1/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/34f0e5a6-0bd3-4734-b7e0-27dc825d193f?source=cve
Get alerted when CVE-2024-8016 or the next vulnerability affects your stack