What’s Vulnerable › Vulnerabilities
CVE-2024-8031: Secure Downloads < 1.2.3 - Admin+ Arbitrary File Download
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.5% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-05-15 · updated 2026-06-17
- Weakness: CWE-552
Description
The Secure Downloads WordPress plugin before 1.2.3 is vulnerable does not properly restrict which files can be downloaded. This makes it possible for authenticated attackers, with admin-level access and above, to download arbitrary files that may contain sensitive information like wp-config.php.
Affected products
- Secure Downloads: before 1.2.3 — fixed in 1.2.3
How to fix
Upgrade to a fixed version: Secure Downloads 1.2.3. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8031 or the next vulnerability affects your stack