What’s Vulnerable › Vulnerabilities
CVE-2024-8045: Advanced WordPress Backgrounds <= 1.12.3 - Authenticated (Contributor+) Stored Cross-Site Scripting via imageTag Parameter
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-11 · updated 2026-06-17
- Weakness: CWE-79
Description
The Advanced WordPress Backgrounds plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘imageTag’ parameter in all versions up to, and including, 1.12.3 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- nko Advanced WordPress Backgrounds: before 1.12.4 — fixed in 1.12.4
How to fix
Upgrade to a fixed version: nko Advanced WordPress Backgrounds 1.12.4. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/advanced-backgrounds/trunk/assets/admin/gutenberg/block.json#L69
- https://plugins.trac.wordpress.org/browser/advanced-backgrounds/trunk/assets/admin/gutenberg/index.min.js
- https://plugins.trac.wordpress.org/browser/advanced-backgrounds/trunk/classes/class-gutenberg.php#L146
- https://plugins.trac.wordpress.org/changeset/3147938/
- https://wordpress.org/plugins/advanced-backgrounds/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/78e49869-5e7e-45f2-8239-4df18b28db53?source=cve
Get alerted when CVE-2024-8045 or the next vulnerability affects your stack