What’s Vulnerable › Vulnerabilities

CVE-2024-8114: Missing Authorization in GitLab

Description

An issue has been discovered in GitLab CE/EE affecting all versions from 8.12 before 17.4.5, 17.5 before 17.5.3, and 17.6 before 17.6.1. This issue allows an attacker with access to a victim's Personal Access Token (PAT) to escalate privileges.

Affected products

How to fix

Upgrade to a fixed version: GitLab 17.4.5, 17.5.3. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-8114 or the next vulnerability affects your stack