What’s Vulnerable › Vulnerabilities
CVE-2024-8156: Command Injection in significant-gravitas/autogpt
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.7% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-03-20 · updated 2026-06-17
- Weakness: CWE-77
Description
A command injection vulnerability exists in the workflow-checker.yml workflow of significant-gravitas/autogpt. The untrusted user input `github.head.ref` is used insecurely, allowing an attacker to inject arbitrary commands. This vulnerability affects versions up to and including the latest version. An attacker can exploit this by creating a branch name with a malicious payload and opening a pull request, potentially leading to reverse shell access or theft of sensitive tokens and keys.
Affected products
- Agpt Autogpt Classic: before 0.5.1 — fixed in 0.5.1
How to fix
Upgrade to a fixed version: Agpt Autogpt Classic 0.5.1. Check the vendor advisory for mitigations.
References
- https://github.com/significant-gravitas/autogpt/commit/1df7d527dd37dff8363dc162fb58d300f072e302
- https://huntr.com/bounties/959efe87-f109-4cef-94d8-90ff2c7aef51
- https://huntr.com/bounties/959efe87-f109-4cef-94d8-90ff2c7aef51
Get alerted when CVE-2024-8156 or the next vulnerability affects your stack