What’s Vulnerable › Vulnerabilities
CVE-2024-8160
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.6% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-26 · updated 2026-06-17
- Weakness: CWE-1286
Description
Erik de Jong, member of the AXIS OS Bug Bounty Program, has found that the VAPIX API ftptest.cgi did not have a sufficient input validation allowing for a possible command injection leading to being able to transfer files from/to the Axis device. This flaw can only be exploited after authenticating with an administrator-privileged service account. Axis has released patched AXIS OS versions for the highlighted flaw. Please refer to the Axis security advisory for more information and solution.
Affected products
- Axis Communications AB AXIS OS: from 10.9.0 before 12.1.21 — fixed in 12.1.21
- Axis Os 2022: before 10.12.257 — fixed in 10.12.257
- Axis Os 2024: before 11.11.116 — fixed in 11.11.116
How to fix
Upgrade to a fixed version: Axis Communications AB AXIS OS 12.1.21; Axis Os 2022 10.12.257; Axis Os 2024 11.11.116. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8160 or the next vulnerability affects your stack