What’s Vulnerable › Vulnerabilities
CVE-2024-8180: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-11-14 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue has been discovered in GitLab CE/EE affecting all versions from 17.3 before 17.3.7, 17.4 before 17.4.4, and 17.5 before 17.5.2. Improper output encoding could lead to XSS if CSP is not enabled.
Affected products
- GitLab: from 17.3.0 before 17.3.7; from 17.4.0 before 17.4.4; from 17.5.0 before 17.5.2 — fixed in 17.3.7, 17.4.4, 17.5.2
How to fix
Upgrade to a fixed version: GitLab 17.3.7, 17.4.4, 17.5.2. Check the vendor advisory for mitigations.
References
- https://about.gitlab.com/releases/2024/11/13/patch-release-gitlab-17-5-2-released/#html-injection-in-vulnerability-code-flow-could-lead-to-xss-on-self-hosted-instances
- https://gitlab.com/gitlab-org/gitlab/-/issues/480720
- https://hackerone.com/reports/2654010
Get alerted when CVE-2024-8180 or the next vulnerability affects your stack