What’s Vulnerable › Vulnerabilities
CVE-2024-8184: Jetty ThreadLimitHandler.getRemote() vulnerable to remote DoS attacks
- Severity: medium (CVSS 6.5 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 1.0% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-10-14 · updated 2026-06-17
- Weakness: CWE-400
Description
There exists a security vulnerability in Jetty's ThreadLimitHandler.getRemote() which can be exploited by unauthorized users to cause remote denial-of-service (DoS) attack. By repeatedly sending crafted requests, attackers can trigger OutofMemory errors and exhaust the server's memory.
Affected products
- The Eclipse Foundation Eclipse Jetty: from 9.3.12 before 9.4.56; from 10.0.0 before 10.0.24; from 11.0.0 before 11.0.24; from 12.0.0 before 12.0.9 — fixed in 10.0.24, 11.0.24, 12.0.9, 9.4.56
How to fix
Upgrade to a fixed version: The Eclipse Foundation Eclipse Jetty 10.0.24, 11.0.24, 12.0.9, 9.4.56. Check the vendor advisory for mitigations.
References
- https://github.com/jetty/jetty.project/pull/11723
- https://github.com/jetty/jetty.project/security/advisories/GHSA-g8m5-722r-8whq
- https://gitlab.eclipse.org/security/cve-assignement/-/issues/30
- https://lists.debian.org/debian-lts-announce/2025/04/msg00001.html
Get alerted when CVE-2024-8184 or the next vulnerability affects your stack