What’s Vulnerable › Vulnerabilities
CVE-2024-8186: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') in GitLab
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2025-03-03 · updated 2026-06-17
- Weakness: CWE-79
Description
An issue has been discovered in GitLab CE/EE affecting all versions from 16.6 before 17.7.6, 17.8 before 17.8.4, and 17.9 before 17.9.1. An attacker could inject HMTL into the child item search potentially leading to XSS in certain situations.
Affected products
- GitLab: from 16.6.0 before 17.7.6; from 17.8.0 before 17.8.4; 17.9.0 — fixed in 17.7.6, 17.8.4
How to fix
Upgrade to a fixed version: GitLab 17.7.6, 17.8.4. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8186 or the next vulnerability affects your stack