What’s Vulnerable › Vulnerabilities

CVE-2024-8215: Payload Injection Attack via Management REST interface

Description

Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Payara Platform Payara Server (Admin Console modules) allows Remote Code Inclusion.This issue affects Payara Server: from 5.20.0 before 5.68.0, from 6.0.0 before 6.19.0, from 6.2022.1 before 6.2024.10, from 4.1.2.191.1 before 4.1.2.191.51.

Affected products

How to fix

Upgrade to a fixed version: Payara Platform Payara Server 4.1.2.191.51, 5.68.0, 6.2024.10. Check the vendor advisory for mitigations.

References

Get alerted when CVE-2024-8215 or the next vulnerability affects your stack