What’s Vulnerable › Vulnerabilities
CVE-2024-8241: Nova Blocks by Pixelgrade <= 2.1.7 - Authenticated (Contributor+) Stored Cross-Site Scripting via align Attribute
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-10 · updated 2026-06-17
- Weakness: CWE-79
Description
The Nova Blocks by Pixelgrade plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'align' attribute of the 'wp:separator' Gutenberg block in all versions up to, and including, 2.1.7 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- pixelgrade Nova Blocks: before 2.1.8 — fixed in 2.1.8
How to fix
Upgrade to a fixed version: pixelgrade Nova Blocks 2.1.8. Check the vendor advisory for mitigations.
References
- https://github.com/pixelgrade/nova-blocks/commit/655b5b804306c3ca3a59707cc2f12098e193b4ca
- https://plugins.trac.wordpress.org/changeset/3148752/
- https://wordpress.org/plugins/nova-blocks/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/3011befd-c0c6-4800-a370-e592c3ec483f?source=cve
Get alerted when CVE-2024-8241 or the next vulnerability affects your stack