What’s Vulnerable › Vulnerabilities
CVE-2024-8253: Post Grid and Gutenberg Blocks 2.2.87 - 2.2.90 - Authenticated (Subscriber+) Privilege Escalation
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 9.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-11 · updated 2026-06-17
- Weakness: CWE-266
Description
The Post Grid and Gutenberg Blocks plugin for WordPress is vulnerable to privilege escalation in all versions 2.2.87 to 2.2.90. This is due to the plugin not properly restricting what user meta values can be updated and ensuring a form is active. This makes it possible for authenticated attackers, with subscriber-level access and above, to update their user meta to become an administrator.
Affected products
- pickplugins Post Grid: from 2.2.87 before 2.2.91 — fixed in 2.2.91
How to fix
Upgrade to a fixed version: pickplugins Post Grid 2.2.91. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/post-grid/trunk/includes/blocks/form-wrap/functions.php#L3032
- https://plugins.trac.wordpress.org/changeset/3130155/post-grid/tags/2.2.87/includes/blocks/form-wrap/functions.php
- https://plugins.trac.wordpress.org/changeset/3146752/post-grid/tags/2.2.91/includes/blocks/form-wrap/functions.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f5f18cae-b7f8-4afd-adfa-c616c63f9419?source=cve
Get alerted when CVE-2024-8253 or the next vulnerability affects your stack