What’s Vulnerable › Vulnerabilities
CVE-2024-8263
- Severity: low (CVSS 2.7 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-23 · updated 2026-06-17
- Weakness: CWE-269
Description
An improper privilege management vulnerability allowed arbitrary workflows to be committed using an improperly scoped PAT through the use of nested tags. This vulnerability affected all versions of GitHub Enterprise Server and was fixed in version 3.10.17, 3.11.15, 3.12.9, 3.13.4, and 3.14.1. This vulnerability was reported via the GitHub Bug Bounty program.
Affected products
- GitHub Enterprise Server: from 3.10.0 before 3.10.17; from 3.11.0 before 3.11.15; from 3.12.0 before 3.12.9; from 3.13.0 before 3.13.4; 3.14.0 — fixed in 3.10.17, 3.11.15, 3.12.9, 3.13.4
How to fix
Upgrade to a fixed version: GitHub Enterprise Server 3.10.17, 3.11.15, 3.12.9, 3.13.4. Check the vendor advisory for mitigations.
References
- https://docs.github.com/en/enterprise-server@3.10/admin/release-notes#3.10.17
- https://docs.github.com/en/enterprise-server@3.11/admin/release-notes#3.11.15
- https://docs.github.com/en/enterprise-server@3.12/admin/release-notes#3.12.9
- https://docs.github.com/en/enterprise-server@3.13/admin/release-notes#3.13.4
- https://docs.github.com/en/enterprise-server@3.14/admin/release-notes#3.14.1
Get alerted when CVE-2024-8263 or the next vulnerability affects your stack