What’s Vulnerable › Vulnerabilities
CVE-2024-8266: Execution with Unnecessary Privileges in GitLab
- Severity: medium (CVSS 6.6 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: yes
- Published: 2025-02-13 · updated 2026-06-17
- Weakness: CWE-250
Description
An issue was discovered in GitLab CE/EE affecting all versions starting from 17.1 prior to 17.6.0, which allows an attacker with maintainer role to trigger a pipeline as project owner under certain circumstances.
Affected products
- GitLab: from 17.1.0 before 17.6.0 — fixed in 17.6.0
How to fix
Upgrade to a fixed version: GitLab 17.6.0. Check the vendor advisory for mitigations.
References
Get alerted when CVE-2024-8266 or the next vulnerability affects your stack