What’s Vulnerable › Vulnerabilities
CVE-2024-8267: Radio Player – Live Shoutcast, Icecast and Any Audio Stream Player for WordPress <= 2.0.78 - Authenticated (Contributor+) Stored Cross-Site Scripting via align Attribute
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.3% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-25 · updated 2026-06-17
- Weakness: CWE-79
Description
The Radio Player – Live Shoutcast, Icecast and Any Audio Stream Player for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'align' attribute within the 'wp:radio-player' Gutenberg block in all versions up to, and including, 2.0.78 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- princeahmed Radio Player – Live Shoutcast, Icecast and Any Audio Stream Player: before 2.0.79 — fixed in 2.0.79
How to fix
Upgrade to a fixed version: princeahmed Radio Player – Live Shoutcast, Icecast and Any Audio Stream Player 2.0.79. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/radio-player/trunk/block/class-block.php#L26
- https://plugins.trac.wordpress.org/changeset/3152379/
- https://plugins.trac.wordpress.org/changeset/3152379/radio-player/trunk/block/class-block.php
- https://wordpress.org/plugins/radio-player/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/49581614-14a8-4450-8f83-d8d22a3feee9?source=cve
Get alerted when CVE-2024-8267 or the next vulnerability affects your stack