What’s Vulnerable › Vulnerabilities
CVE-2024-8268: Frontend Dashboard <= 2.2.4 - Authenticated (Subscriber+) Arbitrary Function Call
- Severity: high (CVSS 8.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.7% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-10 · updated 2026-06-17
- Weakness: CWE-94
Description
The Frontend Dashboard plugin for WordPress is vulnerable to unauthorized code execution due to insufficient filtering on callable methods/functions via the ajax_request() function in all versions up to, and including, 2.2.4. This makes it possible for authenticated attackers, with subscriber-level access and above, to call arbitrary functions that can be leverage for privilege escalation by changing user's passwords.
Affected products
- vinoth06 Frontend Dashboard: before 2.2.5 — fixed in 2.2.5
How to fix
Upgrade to a fixed version: vinoth06 Frontend Dashboard 2.2.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/frontend-dashboard/tags/2.2.4/route/class-fed-request.php#L29
- https://plugins.trac.wordpress.org/changeset/3147868/frontend-dashboard/tags/2.2.5/route/class-fed-request.php?old=3048034&old_path=frontend-dashboard%2Ftags%2F2.2.4%2Froute%2Fclass-fed-request.php
- https://www.wordfence.com/threat-intel/vulnerabilities/id/7d66694a-c99f-44f8-8004-1a47ad9f9250?source=cve
Get alerted when CVE-2024-8268 or the next vulnerability affects your stack