What’s Vulnerable › Vulnerabilities
CVE-2024-8275: The Events Calendar <= 6.6.4 - Unauthenticated SQL Injection
- Severity: critical (CVSS 9.8 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 49.9% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-09-25 · updated 2026-06-17
- Weakness: CWE-89
Description
The The Events Calendar plugin for WordPress is vulnerable to SQL Injection via the 'order' parameter of the 'tribe_has_next_event' function in all versions up to, and including, 6.6.4 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. Only sites that have manually added tribe_has_next_event() will be vulnerable to this SQL injection.
Affected products
- stellarwp The Events Calendar: before 6.6.4.1 — fixed in 6.6.4.1
How to fix
Upgrade to a fixed version: stellarwp The Events Calendar 6.6.4.1. Check the vendor advisory for mitigations.
References
- https://docs.theeventscalendar.com/reference/functions/tribe_has_next_event/
- https://plugins.trac.wordpress.org/changeset?sfp_email=&sfph_mail=&reponame=&old=3152853%40the-events-calendar&new=3152853%40the-events-calendar&sfp_email=&sfph_mail=#file18
- https://theeventscalendar.com/knowledgebase/customizing-template-files-2-legacy/
- https://www.wordfence.com/threat-intel/vulnerabilities/id/f59891c7-db1a-4688-8616-8877d7d7960d?source=cve
Get alerted when CVE-2024-8275 or the next vulnerability affects your stack