What’s Vulnerable › Vulnerabilities
CVE-2024-8276: WPZOOM Portfolio Lite – Filterable Portfolio Plugin <= 1.4.4 - Authenticated (Contributor+) Stored Cross-Site Scripting via align Attribute
- Severity: medium (CVSS 5.4 v3.1)
- Exploited in the wild: not listed in CISA KEV
- EPSS: 0.4% probability of exploitation in the next 30 days
- Public exploit or detection template: none known
- Published: 2024-08-31 · updated 2026-06-17
- Weakness: CWE-79
Description
The WPZOOM Portfolio Lite – Filterable Portfolio Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘align’ attribute within the 'wp:wpzoom-blocks' Gutenberg block in all versions up to, and including, 1.4.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Affected products
- WPZOOM Portfolio: before 1.4.5 — fixed in 1.4.5
How to fix
Upgrade to a fixed version: WPZOOM Portfolio 1.4.5. Check the vendor advisory for mitigations.
References
- https://plugins.trac.wordpress.org/browser/wpzoom-portfolio/trunk/build/blocks/portfolio-layouts/index.php#L63
- https://plugins.trac.wordpress.org/changeset/3144394
- https://wordpress.org/plugins/wpzoom-portfolio/#developers
- https://www.wordfence.com/threat-intel/vulnerabilities/id/2e7d5503-0a6e-4611-bb7c-b2871be828be?source=cve
Get alerted when CVE-2024-8276 or the next vulnerability affects your stack